Instalación de Bugzilla en windows

De ChuWiki
Revisión del 16:32 29 ago 2006 de Chuidiang (Discusión | contribuciones) (creado)

(dif) ← Revisión anterior | Revisión actual (dif) | Revisión siguiente → (dif)
Saltar a: navegación, buscar

Instalación de bugzilla en windows

Bugzilla es un conjunto de páginas php que nos pemiten llevar una base de datos de incidencias de un proyecto. Supuestamente, cuando alguien da de alta una incidencia, envía correos a las personas implicadas y los devuelve cuando las incidencias se van corrigiendo.

Necesita un servidor web con php y base de datos. En la instalación yo tengo apache, php y mysql sobre windows. También necesita perl, así que hay que instalarlo.

  • Bugzilla se puede bajar de [1] y me bajo la 2.22 que es la última estable en este momento.
  • Una vez bajado el fichero, lo desempaqueto en el directorio de mi sitio web donde quiero que corra bugzilla. Me crea un subdirectorio bugzilla-2.22 y dentro un montón de ficheros.
  • Instalo perl que es necesario. Una vez hecho, abro una ventana de ms-dos, voy al directorio bugzilla-2.22 y ejecuto
c:\> perl checksetup.pl

esto me indica si tengo o no todo lo necesario para correr bugzilla. De momento me da errores de que necesito ciertos módulos de perl adicionales

Bugzilla requires some Perl modules which are either missing from
your system, or the version on your system is too old.
They can be installed by running (as Administrator) the following:
   ppm install MailTools
   Minimum version required: 1.67
   ppm install MIME-Tools
   Minimum version required: 5.406
   ppm install AppConfig
   Minimum version required: 1.52
   ppm install Template-Toolkit
   Minimum version required: 2.08
   ppm install TimeDate
   Minimum version required: 2.21
   ppm install DBI
   Minimum version required: 1.38

así que me toca instalarlos...